Systémové požadavky 

Klient Nala vyžaduje ke svému běhu PHP ve verzi 5.6 a vyšší. Dále je nutné mít nainstalována následující PHP rozšíření:

  • curl
  • date
  • filter
  • hash
  • json
  • mbstring
  • pcre
  • session
  • spl
  • standard

Instalace

  • Stažení zabalené instance NALA klienta z Vaší administrace (https://admin.nala.one/).
  • Stažený zip soubor je nutno rozbalit na FTP prostor Vašeho klienta do vybraného adresáře.
  • Dalším krokem je vložit php soubor nClient.php do všech php souborů, ve kterých bude NALA využívána.

Příklad vložení v případě, že klient NALA je nainstalován v adresáři „nala“.

example

  • Dále je nutné u této instance klienta ve Vaší NALA administraci vložit cestu k souboru api.php, nahraném na Vašem FTP.

Pokud by byl například klient NALA nainstalován na adrese https://www.nala.one v adresáři nala, pak by tato cesta byla „https://www.nala.one/nala/api.php“.

Tento krok je nezbytný a vaše instance bez něj nebude aktivována. V tomto kroku klient NALA zároveň ověří možnost zápisu a čtení ze složky, ve které je nainstalován.